Debian 4.0 – Postfix Kurulumu – 1

Postfix bildiğiniz üzere son zamanların en moda mail sunucusu… Yıllardır Qmail kullanmama rağmen artık modasının geçtiğini söylemekten çekinmiyorum. Bu yazımızdan Virtual User ve Virtual domain oluşturabileceğimiz bir postfix kuracağız. İşletim sistemimizde Debian 4.0 Etch olacak… Daha önceki makalelerimizde debian 4.0 Etch kurulumunu vermiştik dilerseniz önce o yazıları ziyaret edip Debian 4.0 kurun…

1. Giriş

Bu yazımızda da daha öncekiler gibi server ip adresi 192.168.1.5 ve server ismi mail.dinopsys.net olacaktır.

2. Postfix, Courier, MySQL ve Saslauthd Kurulumu

Bu paketlerin kurulumu için aşağıdaki komutu çalıştırın ve çıkacak soruya enter diyerek olumlu cevap verin.

apt-get install postfix postfix-mysql postfix-doc mysql-client mysql-server courier-authdaemon courier-authlib-mysql courier-pop courier-pop-ssl courier-imap courier-imap-ssl postfix-tls libsasl2 libsasl2-modules libsasl2-modules-sql sasl2-bin libpam-mysql openssl phpmyadmin apache2 libapache2-mod-php5 php5 php5-mysql

paketlerin download işlemi bitip kurulum başladığında size bazı sorular sorulacak bu soruları aşağıdaki gibi cevaplayın;

Create directories for web-based administration ? <– No
General type of configuration? <– Internet Site
Mail name? <– mail.dinopsys.net
SSL certificate required <– Ok

3. Kota Yamasının Postfix’ e Uygulanması

apt-get install build-essential dpkg-dev fakeroot debhelper libgdbm-dev libldap2-dev libpcre3-dev libssl-dev libsasl2-dev postgresql-dev po-debconf dpatch libdb4.3-dev libmysqlclient15-dev lsb-release libcdb-dev

cd /usr/src
apt-get source postfix

 Buraya kadar hersey normal şimdi ufak bir kontrol yapmanız gerekiyor -> Postfix versiyonu… Bizim test için kurduğumuz 2.3.8 sizde versiyonunuzu görmek için şu komutu kullanabilirsiniz;

postconf -d | grep mail_version

Benim sunucumda bu sorgunun çıktısı;

mail:~# postconf -d | grep mail_version
mail_version = 2.3.8
milter_macro_v = $mail_name $mail_version

)

şeklinde… Versiyonunuz 2.3.8 ise buyrun burdan devam edelim…

wget http://vda.sourceforge.net/VDA/postfix-2.3.8-vda.patch.gz
gunzip postfix-2.3.8-vda.patch.gz
cd postfix-2.3.8
patch -p1 < ../postfix-2.3.8-vda.patch
dpkg-buildpackage

Bu komutun sonunda;

(WARNING: Failed to sign .dsc and .changes file)

böyle bir hata görürseniz dikkate almayın…

Şimdi yeni postfix paketimizi kuralım;

cd ..
dpkg -i postfix_2.3.8-2_i386.deb
dpkg -i postfix-mysql_2.3.8-2_i386.deb

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

This site uses Akismet to reduce spam. Learn how your comment data is processed.